PDFと「楽譜を読み取る」
記譜アプリやTAB譜アプリが書き出したPDFは、音楽を描かれた線や文字として持っていて、Stabはそれを読み戻します。ノートとそのリズム、TAB譜のフレット、ドラム、ページの言葉。スキャンしたPDFは代わりにページの画像を持っていて、Stabは写真と同じようにそれも読みます。PDFは曲とともにその横に残るので、読み取ったものをページと照らして確認できます。
PDFと「楽譜を読み取る」
対応:すべてのプラットフォーム。
Stabが読むもの
Stabは、アプリで作られたPDF(Stabを含む記譜やTAB譜のプログラムから書き出したか、PDFとしてプリントしたもの)とスキャンしたPDFを読みます。そのページで読むもの:
- 記譜:音部記号、調号と拍子記号、1段につき2つまでのボイスのノートと休符、臨時記号、連符、タイ、弱起の小節、繰り返しとエンディング、テンポ記号。
- TAB譜:各弦のフレットと、ページに書かれていればチューニング。譜表の下にリズムを付けてTAB譜だけを印刷したものも読みます。
- ドラム(打楽器の譜表)。
- ページの文字:タイトル、歌詞、コードシンボル、セクション名。
段やページをまたぐパートは、それぞれ1つのトラックにつながります。
スキャンしたPDF
スキャンしたPDFは、描かれた音楽ではなくページの画像を持っています。Stabは写真と同じように読みます。各ページを整えてまっすぐにし、譜表を見つけ、コンピューター上で動く「楽譜を読み取る」のモデルがその上の記号を認識します。曲はスキャンしたページの横に開き、ページは自動で1つずつ読み取られます。画像パネルの下部にどこまで進んだか、その後は読み取った小節の数と確認が必要な数が表示されます。1ページに数秒かかります(Appleシリコン搭載Macの場合。Intel Macでは最大15秒ほど)。
描かれたページとスキャンしたページの両方があるPDFは、描かれたページをすぐに読み、スキャンしたページをその後に、同じ曲に読みます。スキャンしたページは、PDFの横にそれ自体の書類として保持されます。
スキャンの読み取りは描かれたPDFより不確かなので、確認する小節は多めになります。300 dpiでスキャンした、くっきりとまっすぐなページがいちばんよく読めます。薄い、ぼやけた、とても小さい印刷はあまりよく読めず、手書きの楽譜は読みません。楽譜を書いたプログラムがあれば、そこから書き出したPDFは正確に読めます。楽譜の読み取りのトラブルシューティングを参照してください。
PDFを開く
- ファイルメニューから開く… (⌘O)開く… (Ctrl+O)読み込む…を選ぶか、ホームの曲を取り込むの下のファイルを読み込むを選びます。 ホームの曲を取り込むの下で、ファイルを読み込むを選びます。
- PDFを選びます。
曲は、左にスコア、右にPDFのページを表示する画像パネルがあり、その2つがリンクした状態で開きます。メッセージに、読み取った小節の数と確認が必要な数が表示されます。曲は他の読み込みと同じくライブラリに入り、最初のページのタイトル、なければファイルの名前が付きます。Webでは曲は試用のデモとして開きます。離れるときにStab Cloudに保存で残せます(Welcomeのデモを参照)。
そのメッセージでは、読み方も選べます:Windowsでは、それ自体のダイアログです。
- ページのレイアウトを保持は、スコアで印刷された段、符尾、連桁、綴りを保ちます。新しくレイアウトするでは、Stabが自分の曲と同じようにレイアウトします。
- 不確かな小節:最も確からしい結果を保持か、空のままにする(小節の長さの休符)。どちらでも、その小節は確認が必要なものとして印が残ります。
- リピート記号:保持する(反復記号とエンディング)か、除外する(印刷どおり、小節を1回)。
- 確認で、確認する小節をすぐに順に見ていきます(下記)。
オプションを変えると、PDFはそれでもう一度読み取られます。選んだものは、次のPDFと「楽譜を読み取る」のために記憶されます。設定にも同じ選択肢があります(編集 › 印刷された楽譜の読み取りスコアのページの「楽譜を読み取る」の行)。レイアウトは後から、スコアパネルの⚙のレイアウトをやり直すで変えられます。
スコアはページのレイアウト、つまり段、符尾、連桁、綴りを保ちます。スコアパネルの⚙のレイアウトをやり直すで、Stabが自分の曲と同じようにレイアウトします。手で設定した符尾、連桁、段またぎの選択も消去されます(レイアウトをやり直す)。不確かな小節と繰り返しの読み方は、設定(スコア › 印刷された楽譜の読み取り)と画像パネルのメニューにあります。
読み取ったものを確認する
印刷された楽譜の読み取りは完璧ではないので、Stabは確信が低かった場所を伝えます:
- 画像パネルは、ページ上の確認が必要な小節を枠で囲み、曲を開くときのメッセージにその数が表示されます。
- 次の確認する小節で、それぞれに順に移動します。
- 確認で、1つずつ見ていきます(下記)。
- エディターでは、ノートの色分け › 信頼度で、各ノートを読み取りの確かさで色分けします。
小節をページと比べ、再生し、間違っているところを他のノートと同じように直します。確認が必要と印の付いた小節のノートを編集すると、確認済みになります。
| コマンド | キー | 場所 |
|---|---|---|
| 開く… | ⌘O | ファイルメニュー; ホーム › Import… |
| コマンド | キー | 場所 |
|---|---|---|
| 開く… | Ctrl+O | ファイルメニュー; ホーム › Import… |
| コマンド | キー | 場所 |
|---|---|---|
| 読み込む… | ホーム |
読み取った内容の確認
対応:すべてのプラットフォーム。
確認では、確認する小節を1つずつ、ページ上のその領域の横に表示します。画像パネルの横のスコアかエディターがその小節に移動し、ページはそこまでスクロールして枠で囲みます。読み取りの後の画像パネルの下部の確認、編集メニューの読み取った小節を確認、PDFを開いた後のメッセージの確認、または画像パネルのメニューの読み取った小節を確認で始めます。
画像パネルの上部の帯に、今の位置(「確認 · 3/9」)が表示され、表示中の小節に対して次のものがあります:
- 承認:小節はそのままで正しいものです。確認の印が外れ、次に進みます。
- 修正:確認はノートを選択した状態でその小節で待ちます。スコアパネルがキーボードを受け取ります。スコアのツールで編集し、それから確認を再開(スコアの上のピル、帯、またはメニュー)で続けます。
- 再読み取り:ページ上のその小節の領域だけをもう一度読み取ります。
- 空のままにする:小節の長さの休符で、確認の印は残ります。
- 新しい読み取り結果を使う:ページやクリップがもう一度読み取られる前に編集していた小節に、別に取っておいた新しい読み取り結果を使います。
- ‹と›で前後に移動し、完了で確認を終えます。
それぞれが1回の取り消しステップです。確認の間は、曲のどのパネルでもキーが働きます。Returnで承認、矢印で移動、Escapeで終了、F、R、E、Nで修正、再読み取り、空のままにする、新しい読み取り結果を使う。最後の小節を過ぎると確認が終わり、確認が残っている数が表示されます。
| コマンド | キー | 場所 |
|---|---|---|
| 読み取った小節を確認 | 編集メニュー | |
| 確認を終了 | 編集メニュー; Review strip | |
| 承認 | Review strip | |
| 修正 | Review strip | |
| 再読み取り | Review strip | |
| 空のままにする | Review strip | |
| 新しい読み取り結果を使用 | Review strip | |
| 次の小節 | Review strip | |
| 前の小節 | Review strip |
| コマンド | キー | 場所 |
|---|---|---|
| 読み取った小節を確認 | 編集メニュー | |
| 確認を終了 | 編集メニュー; Review strip | |
| 承認 | Review strip | |
| 修正 | Review strip | |
| 再読み取り | Review strip | |
| 空のままにする | Review strip | |
| 新しい読み取り結果を使用 | Review strip | |
| 次の小節 | Review strip | |
| 前の小節 | Review strip |
| コマンド | キー | 場所 |
|---|---|---|
| 読み取った小節を確認 | 編集メニュー | |
| 確認を終了 | 編集メニュー; Review strip | |
| 承認 | Review strip | |
| 修正 | Review strip | |
| 再読み取り | Review strip | |
| 空のままにする | Review strip | |
| 新しい読み取り結果を使用 | Review strip | |
| 次の小節 | Review strip | |
| 前の小節 | Review strip |
画像パネル
対応:すべてのプラットフォーム。
画像パネルは、曲の書類の1つを表示します:PDF、または印刷された楽譜の写真。PDFから開いた曲には自動で1つ付きます。その他の曲では、パネルの種類から画像パネルにして(パネル)、書類を加えます。
一緒に読む
ページは縦に並びます。スクロールし、ピンチで拡大縮小するか、パネルのメニューの拡大と縮小を使います。カーソルのある小節はページ上で枠で囲まれます。リンクの色でエディターやスコアにリンクしていると、パネルはそのカーソルに従い、ページの小節をクリックするとそのカーソルがそこに移ります。ページのノートの上にポインタを置くと、そこで何を読み取ったかが表示されます。
パネルのメニュー
パネルを右クリックすると、メニューが開きます:
- 楽譜を読み取る、すべてのページを読み取る(2ページ以上の書類)、領域内の楽譜を読み取る、楽譜を読み取る(クリップとして)、クリップを再読み取り、領域を消去:下記を参照してください。
- 領域を除外、除外ゾーンを削除、このページの除外ゾーンを削除:下記を参照してください。
- 読み取りオプション:上記のページのレイアウトを保持、不確かな小節、リピート記号。
- 次の要確認の小節、読み取った小節を確認(小節の修正中は確認を再開)、確認を終了。
- カーソルに追従、幅に合わせる、拡大、縮小。
- 表示 › 確認が必要な小節、写真では元の写真と五線を枠で表示も。設定(スコア › 印刷された楽譜の読み取り)で読み取りの詳細を表示がオンのときは、「楽譜を読み取る」がページで見たものと作ったもののすべてのレイヤー(譜表、記号、信頼度、テキスト、読み取り、整え)が「表示」に加わります。ポインタを置くと、各記号が何になったかが表示されます。
- レイヤー付きでページを書き出す…:上に描かれたものと一緒にしたページの画像。Stabが何かを読み違えたときに送るためのものです。
- 別のものを表示するための曲の書類、PDFや画像を加える書類を追加…、書類を削除。
書類は曲のファイルの中に保持されます。追加や削除は取り消しステップではありません。
楽譜を読み取る
「楽譜を読み取る」は、ページやその一部を作業中の曲に読み取ります:
- 画像パネルにページを表示し、音楽を入れたい場所にカーソルを置きます(別のパネルで、またはページの小節をクリックして)。
- ページの一部だけを読むには、その周りに四角形をドラッグします:マウスでドラッグします。
- パネルのメニューから、カーソル位置で楽譜を読み取る(まだノートのない曲では楽譜を読み取る)か、領域内の楽譜を読み取るを選びます。
読み取ったものは1回の取り消しステップで入ります。ノートのない曲では、読み取ったパートがそれぞれ、拍子記号、テンポ、調とともにトラックになります。ノートのある曲では、カーソルのトラックに合うパート(フレットのあるトラックにはTAB譜、鍵盤には鍵盤、ドラムにはドラム)が、カーソルの小節から、それ自体のクリップに入ります。すでにクリップがある場所では新しいボイスに入るので、何も上書きされません。すべてのページを読み取るは、書類のすべてのページを、ページの変わり目でつないで曲に読み取ります。
楽譜を読み取る(クリップとして)は、領域を、カーソルのトラックのカーソルの小節に、読み取った小節の長さの新しいクリップとして読み取り、何も上書きしません。クリップはページのどこから来たかを覚えています。その上にポインタを置くとページ上の領域が枠で囲まれ、クリップを再読み取り(クリップのメニュー、またはクリップを選んだ状態の画像パネルのメニュー)でもう一度読み取ります。ページ、領域、クリップをもう一度読み取ると、それ以降に編集していない小節だけが置き換わります。編集した小節は保たれ、確認でその新しい読み取り結果が提示されます。
除外ゾーン
ページには、読むべき音楽でないものもあります:見出し、手書きのメモ、絵、スタンプ。その周りに領域をドラッグし、パネルのメニューから領域を除外を選びます。「除外」と記されたグレーの斜線の枠になり、「楽譜を読み取る」はその下のものを省きます。ゾーンをクリックして選び、ドラッグして移動するか、角をドラッグしてサイズを変えます。除外ゾーンを削除(またはDelete)で取り除きます。ゾーンは曲の中にページとともに保持され、各変更は1回の取り消しステップです。写真は、ページを整えてからゾーンを受け付けます。
| コマンド | キー | 場所 |
|---|---|---|
| 次の確認する小節 | トランスポートメニュー; 画像パネルのメニュー |
| コマンド | キー | 場所 |
|---|---|---|
| 次の確認する小節 | トランスポートメニュー; 画像パネルのメニュー |
| コマンド | キー | 場所 |
|---|---|---|
| 次の確認する小節 | トランスポートメニュー; 画像パネルのメニュー |