stab ヘルプ

14. 曲の取り込み

楽譜の写真

本のページの写真やスキャンを、曲と一緒に置けます。Stabは画像の中のページを見つけ、平らにし、明るさを均一にして、画像パネルでTAB譜の横に表示するので、書いたり弾いたりしながら目で追えます。それから楽譜を読み取るで、その上の音楽をノートに読み取ります(下記)。Webは写真を曲とともに保持して表示しますが、その音楽をノートに読み取りはしません。Mac、PC、iPhone、iPad、AndroidのStabが読み取ります。

印刷された楽譜の写真

まだ利用できません。 Mac、Windows、Webには非対応。

これはMacにはありません。

これはWindowsにはありません。

これはWebにはありません。

写真から新しい曲を作る

  1. ファイルメニューから開く… (⌘O)開く… (Ctrl+O)読み込む…を選ぶか、ホームの曲を取り込むの下の写真かPDFを選びます(または近くにiPhoneかiPadがあれば写真を撮る)。
  2. 画像を選びます。複数のページなら一度に複数、または画像のフォルダーを選びます。ホームや曲のウィンドウにドロップすることもできます。
  1. ホームの曲を取り込むの下でファイルを読み込むを選ぶか、ホームのどこにでも画像をドロップします。
  2. 1枚以上の画像を選びます。

Webにはライブラリがないので、曲は試用のデモとして開き、離れるときにStab Cloudに保存で残せます(Welcomeのデモを参照)。

一緒に開いた画像は1つの曲になり、各画像が選んだ順に1ページになります(フォルダーでは名前の順)。StabはPNG、JPEG、HEIC、TIFF、WebP、BMPの画像を受け付けます(Webではブラウザが開けるもの)。開けないものは省かれ、どれかが伝えられます。

曲は、左にスコア、右に画像パネルのページがある状態で開きます(スマートフォンでは、スコアのタブとリンクした画像のタブ)。写真を整えている間は、パネルの下部にそう表示され、写真は取り込んだままの状態で表示されます。

画像パネルが表示するもの

各ページは整えた状態で表示されます。写真の中で見つかったページの、縁と湾曲をまっすぐにし、明るさを均一にしたものです。パネルのメニュー(パネルを右クリック)では:

  • 表示 › 元の写真で、撮影したときのままで表示します。
  • 表示 › 五線を枠で表示で、Stabが各ページで見つけた譜表を枠で囲みます。
  • 書類を追加…で、ページ(PDFやさらに写真)を曲に加えます。書類を削除で取り除きます。

画像は、整えたページとともに、取り込んだままの状態で曲のファイルの中に保持されます。

音楽を読み取る

画像パネルのメニューからすべてのページを読み取るを選ぶと、すべてのページをページの変わり目でつないで曲に読み取ります。表示中のページには楽譜を読み取るを選びます。数小節だけを読むには、先にその周りに四角形をドラッグして領域内の楽譜を読み取るを選びます(楽譜を読み取る)。コンピューター上で動く「楽譜を読み取る」のモデルが、整えたページの記号を見つけます。1ページに数秒かかり(Appleシリコン搭載Macの場合。Intel Macでは最大15秒ほど)、パネルの下部にどこまで進んだかが表示されます。続きのページの写真は、どんな順で撮っても、印刷されたページ番号で順に並べ直されます。

よく読めるもの:

  • 平らで、均一な明るさで、画像の大部分を占め、運指が読めるほどくっきりした印刷されたページ。
  • PDFと同じく、記譜、TAB譜、ドラム(Stabが読むもの)。

あまり読めないもの、まったく読めないもの:

  • 急な角度で撮影したページ、深い影の中のページ、本の綴じ目に向かって大きく反ったページ。
  • ぼやけた印刷やとても小さい印刷、薄いコピー。
  • 手書きの楽譜は読みません。

画像の読み取りは描かれたPDFより不確かです。ページ上で枠で囲まれた、確認する小節があるものと考えてください。確認で1つずつ見ていきます(読み取ったものを確認する)。

すでにある曲に写真を加える

どの曲でも、パネルの種類から画像パネルにして(パネル)、そのメニューから書類を追加…を選びます。PDFか画像を選びます。画像を画像パネルにドロップすることもできます。

Macにはありません:楽譜の写真…。

Windowsにはありません:楽譜の写真…。

Webにはありません:楽譜の写真…。