stab Hilfe

14. Musik importieren

PDFs und Noten lesen

Ein von einer Notations- oder Tab-App exportiertes PDF enthält die Musik als gezeichnete Linien und Buchstaben, und Stab liest sie zurück: die Noten und ihren Rhythmus, die Bünde der TAB, Schlagzeug und die Texte auf der Seite. Ein gescanntes PDF enthält stattdessen Bilder seiner Seiten, und Stab liest auch diese, wie es Fotos liest. Das PDF bleibt beim Song, daneben, sodass Sie das Gelesene mit der Seite vergleichen können.

PDFs und Noten lesen

Verfügbar auf jede Plattform.

Was Stab liest

Stab liest PDFs, die von einer App erstellt wurden (aus einem Notations- oder Tab-Programm als PDF exportiert oder gedruckt, Stab eingeschlossen), und gescannte PDFs. Auf ihren Seiten liest es:

  • Notation: Schlüssel, Tonart- und Taktvorzeichnungen, Noten und Pausen in bis zu zwei Stimmen pro System, Vorzeichen, N-tolen, Haltebögen, einen Auftakt, Wiederholungen und Klammern, Tempoangaben.
  • TAB: die Bünde auf jeder Saite und die Stimmung, wenn die Seite sie angibt. Allein gedruckte TAB, mit ihrem Rhythmus unter dem System, wird auch gelesen.
  • Schlagzeug, auf einem Schlagzeugsystem.
  • Texte auf der Seite: der Titel, Songtexte, Akkordsymbole und die Namen der Teile.

Stimmen, die über Systeme und Seiten laufen, werden zu je einer Spur verbunden.

Gescannte PDFs

Ein gescanntes PDF enthält Bilder seiner Seiten statt gezeichneter Musik. Stab liest sie wie Fotos: Jede Seite wird aufbereitet und begradigt, ihre Systeme werden gefunden, und das Modell von „Noten lesen“, das auf Ihrem Computer läuft, erkennt die Symbole darauf. Der Song öffnet sich neben den gescannten Seiten, die von selbst gelesen werden, eine nach der anderen; der Fuß des Bild-Bereichs sagt, wie weit es ist, dann wie viele Takte gelesen wurden und wie viele zu prüfen sind. Eine Seite dauert ein paar Sekunden auf einem Mac mit Apple Chip, bis zu etwa 15 auf einem Intel-Mac.

Ein PDF mit beiden Arten von Seiten, gezeichneten und gescannten, liest seine gezeichneten Seiten sofort und seine gescannten danach, in denselben Song. Die gescannten Seiten werden als eigenes Dokument neben dem PDF aufbewahrt.

Einen Scan zu lesen ist unsicherer, als ein gezeichnetes PDF zu lesen, also rechnen Sie mit mehr zu prüfenden Takten. Scharfe, gerade, mit 300 dpi gescannte Seiten lesen sich am besten; blasser, unscharfer oder sehr kleiner Druck liest sich weniger gut, und handgeschriebene Noten werden nicht gelesen. Haben Sie das Programm, in dem die Partitur geschrieben wurde, liest sich ein daraus exportiertes PDF genau. Siehe „Noten lesen“ lag falsch.

Ein gescanntes PDF enthält Bilder seiner Seiten statt gezeichneter Musik, und das Web liest diese nicht: Es sagt das, wenn Sie eines öffnen. Öffnen Sie es in Stab auf einem Mac, einem PC, einem iPhone, einem iPad oder unter Android, die Scans lesen.

Ein PDF öffnen

  1. Wählen Sie Öffnen… (⌘O)Öffnen… (Ctrl+O)Importieren… im Menü „Datei“ oder Datei importieren unter Einen Song importieren auf der Startseite. Wählen Sie auf der Startseite unter Einen Song importieren Datei importieren.
  2. Wählen Sie das PDF.
Sie können das PDF auch auf die Startseite oder das Fenster eines Songs ziehen.
Sie können es auch irgendwo auf die Startseite ziehen. Das Web lädt seinen PDF-Leser, wenn Sie zum ersten Mal eines öffnen.

Der Song öffnet sich mit der Partitur links und einem Bild-Bereich rechts, der die Seiten des PDFs zeigt, beide verknüpft. Eine Meldung sagt, wie viele Takte gelesen wurden und wie viele zu prüfen sind. Der Song kommt wie jeder Import in Ihre Bibliothek, benannt nach dem Titel auf der ersten Seite, sonst nach der Datei.Im Web öffnet sich der Song als Demo zum Ausprobieren; In Stab Cloud behalten beim Verlassen behält ihn (siehe Die Welcome-Demo).

Diese Meldung bietet auch an, wie gelesen werden soll: Unter Windows ist es ein eigener Dialog.

  • Layout der Seite beibehalten behält die gedruckten Systeme, Hälse, Balken und die Schreibweise in der Partitur; Neu setzen lässt Stab sie setzen, wie es seinen eigenen Song setzen würde.
  • Unsichere Takte: Beste Schätzung behalten oder Leer lassen (eine Pause in der Länge des Takts). So oder so bleibt der Takt zum Prüfen markiert.
  • Wiederholungen: Beibehalten (Wiederholungszeichen und Klammern) oder Ignorieren (die Takte einmal, wie gedruckt).
  • Prüfen geht die zu prüfenden Takte sofort durch (siehe unten).

Ändert sich eine Option, wird das PDF damit erneut gelesen. Was Sie wählen, wird für das nächste PDF und für „Noten lesen“ gemerkt; die Einstellungen haben dieselbe Wahl (Bearbeitung › Gedruckte Noten lesendie Zeilen „Noten lesen“ der Seite Partitur). Sie können das Layout später mit Neu setzen im ⚙-Menü des Partitur-Bereichs ändern.

Die Partitur behält das Layout der Seite: ihre Systeme, Hälse, Balken und Schreibweise. Neu setzen im ⚙-Menü des Partitur-Bereichs setzt sie, wie Stab seinen eigenen Song setzen würde. Es löscht auch die Hals-, Balken- und Systemwechsel-Entscheidungen, die Sie von Hand gesetzt haben (Seitenansicht, System- und Seitenumbrüche). Wie unsichere Takte und Wiederholungen gelesen werden, steht in den Einstellungen (Partitur › Gedruckte Noten lesen) und im Menü des Bild-Bereichs.

Prüfen, was gelesen wurde

Gedruckte Noten zu lesen ist nicht perfekt, und Stab sagt Ihnen, wo es weniger sicher war:

  • Der Bild-Bereich umrandet die zu prüfenden Takte auf der Seite, und die Meldung beim Öffnen des Songs sagt, wie viele es sind.
  • Nächster zu prüfender Takt geht der Reihe nach zu jedem.
  • Prüfen führt Sie einzeln durch sie hindurch (unten).
  • Im Editor färbt Noten färben nach › Sicherheit jede Note danach, wie sicher das Lesen war.

Vergleichen Sie einen Takt mit der Seite, spielen Sie ihn ab und korrigieren Sie, was falsch ist, wie bei jeder Note. Eine Note in einem zum Prüfen markierten Takt zu bearbeiten, markiert ihn als geprüft.

BefehlTastenWo
Öffnen…⌘Odas Menü „Datei“; die Startseite › Import…
BefehlTastenWo
Öffnen…Ctrl+Odas Menü „Datei“; die Startseite › Import…
BefehlTastenWo
Importieren…die Startseite

Gelesenes prüfen

Verfügbar auf jede Plattform.

„Prüfen“ zeigt die zu prüfenden Takte einzeln, jeden neben seiner Region auf der Seite: Partitur oder Editor neben dem Bild-Bereich gehen zum Takt, und die Seite scrollt zu ihm und umrandet ihn. Starten Sie es mit Prüfen am Fuß des Bild-Bereichs nach einem Lesen, Gelesene Takte prüfen im Menü „Bearbeiten“, Prüfen in der Meldung nach dem Öffnen eines PDFs oder Gelesene Takte prüfen im Menü des Bild-Bereichs.

Ein Streifen oben im Bild-Bereich sagt, wo Sie sind („Prüfung · 3 von 9“), und bietet für den gezeigten Takt:

  • Annehmen: Der Takt stimmt, wie er ist; er ist nicht mehr zum Prüfen markiert, und „Prüfen“ geht weiter.
  • Korrigieren: „Prüfen“ wartet beim Takt, seine Noten ausgewählt, und der Partitur-Bereich übernimmt die Tastatur. Bearbeiten Sie ihn mit den Werkzeugen der Partitur und wählen Sie dann Prüfung fortsetzen (auf der Plakette über der Partitur, im Streifen oder in den Menüs), um weiterzumachen.
  • Neu lesen: Die Region des Takts auf der Seite wird allein erneut gelesen.
  • Leer lassen: eine Pause in der Länge des Takts, weiterhin zum Prüfen markiert.
  • Neue Lesung verwenden: für einen Takt, den Sie bearbeitet hatten, bevor eine Seite oder ein Clip erneut gelesen wurde, die für ihn beiseitegelegte neue Lesung.
  • ‹ und › gehen zurück und weiter; Fertig beendet „Prüfen“.

Jeder davon ist ein Rückgängig-Schritt. Während „Prüfen“ läuft, wirken Tasten in jedem Bereich des Songs: Return nimmt an, die Pfeile gehen weiter, Esc beendet es, und F, R, E und N korrigieren, lesen neu, lassen leer und verwenden die neue Lesung. Über den letzten Takt hinauszugehen, beendet „Prüfen“ und sagt, wie viele noch zu prüfen sind.

BefehlTastenWo
Gelesene Takte prüfendas Menü „Bearbeiten“
Prüfung beendendas Menü „Bearbeiten“; Review strip
AnnehmenReview strip
KorrigierenReview strip
Neu lesenReview strip
Leer lassenReview strip
Neue Lesung verwendenReview strip
Nächster TaktReview strip
Vorheriger TaktReview strip
BefehlTastenWo
Gelesene Takte prüfendas Menü „Bearbeiten“
Prüfung beendendas Menü „Bearbeiten“; Review strip
AnnehmenReview strip
KorrigierenReview strip
Neu lesenReview strip
Leer lassenReview strip
Neue Lesung verwendenReview strip
Nächster TaktReview strip
Vorheriger TaktReview strip
BefehlTastenWo
Gelesene Takte prüfendas Menü „Bearbeiten“
Prüfung beendendas Menü „Bearbeiten“; Review strip
AnnehmenReview strip
KorrigierenReview strip
Neu lesenReview strip
Leer lassenReview strip
Neue Lesung verwendenReview strip
Nächster TaktReview strip
Vorheriger TaktReview strip

Der Bild-Bereich

Verfügbar auf jede Plattform.

Ein Bild-Bereich zeigt eines der Dokumente eines Songs: ein PDF oder Fotos gedruckter Noten. Ein aus einem PDF geöffneter Song bekommt von selbst einen; in jedem anderen Song machen Sie einen Bereich über seine Art zu einem Bild-Bereich (Bereiche) und fügen ihm ein Dokument hinzu.

Mitlesen

Die Seiten laufen untereinander. Scrollen Sie durch sie, ziehen Sie zwei Finger auf oder zu, um zu zoomen, oder nutzen Sie Vergrößern und Verkleinern im Menü des Bereichs. Der Takt am Cursor ist auf der Seite umrandet. Mit dem Editor oder der Partitur über eine Verknüpfungsfarbe verknüpft, folgt der Bereich ihrem Cursor, und ein Klick auf einen Takt der Seite setzt ihren Cursor darauf. Mit dem Zeiger über einer Note der Seite sagt er, was dort gelesen wurde.

Das Menü des Bereichs

Ein Rechtsklick in den Bereich für sein Menü:

  • Noten lesen, Alle Seiten lesen (ein Dokument mit zwei Seiten oder mehr), Noten lesen in der Region, Noten lesen als Clip, Clip neu lesen, Region leeren: siehe unten.
  • Region ignorieren, Ignorierte Zone entfernen, Ignorierte Zonen auf dieser Seite entfernen: siehe unten.
  • Leseoptionen: Layout der Seite beibehalten, Unsichere Takte und Wiederholungen, wie oben.
  • Nächster zu prüfender Takt, Gelesene Takte prüfen (Prüfung fortsetzen, während Sie einen Takt korrigieren), Prüfung beenden.
  • Dem Cursor folgen, An Breite anpassen, Vergrößern, Verkleinern.
  • Anzeigen › Zu prüfende Takte, und bei Fotos Originalfotos und Systeme umranden. Mit eingeschaltetem Lesedetails anzeigen in den Einstellungen (Partitur › Gedruckte Noten lesen) fügt „Anzeigen“ jede Ebene dessen hinzu, was „Noten lesen“ auf der Seite gesehen und daraus gemacht hat (Systeme, Symbole, Sicherheit, Text, die Lesung, die Aufbereitung), und der Zeiger sagt, was aus jedem Symbol wurde.
  • Seite mit Ebenen exportieren…: ein Bild der Seite mit dem, was darübergezeichnet ist, zum Senden, wenn Stab etwas falsch gelesen hat.
  • Die Dokumente des Songs, um ein anderes zu zeigen; Dokument hinzufügen…, um ein PDF oder Bilder hinzuzufügen; Dokument entfernen.
Auf der Seite eines Songbooks mit mehreren Stücken wählt Leseoptionen › Mehrere Stücke auf einer Seite zwischen Als einen Song lesen (ein Marker an jedem Stück) und Jedes als eigenen Song lesen (das erste dort, wo Sie lesen, die anderen als eigene neue Songs).

Ein Dokument wird in der Datei des Songs aufbewahrt. Eines hinzuzufügen oder zu entfernen, ist kein Rückgängig-Schritt.

Noten lesen

„Noten lesen“ liest eine Seite, oder einen Teil davon, in den Song, an dem Sie arbeiten:

  1. Zeigen Sie die Seite im Bild-Bereich und setzen Sie den Cursor dorthin, wo die Musik hinkommen soll (in einem anderen Bereich oder durch einen Klick auf einen Takt der Seite).
  2. Um nur einen Teil der Seite zu lesen, ziehen Sie ein Rechteck darum: Ziehen Sie mit der Maus.
  3. Wählen Sie im Menü des Bereichs Noten lesen am Cursor (Noten lesen in einem Song ohne Noten) oder Noten lesen in der Region.

Was gelesen wird, kommt als ein Rückgängig-Schritt hinein. In einen Song ohne Noten wird jede gelesene Stimme eine Spur, mit ihrer Taktart, ihrem Tempo und ihrer Tonart. In einen Song mit Noten kommt die Stimme, die zur Spur des Cursors passt (Tabs auf einer Bundspur, Tasten auf Tasten, Schlagzeug auf Schlagzeug), dorthin, ab dem Takt des Cursors, in einem eigenen Clip; wo schon ein Clip ist, kommt sie in eine neue Stimme, sodass nichts überschrieben wird. Alle Seiten lesen liest jede Seite des Dokuments in den Song, über die Seitenwechsel hinweg verbunden.

Noten lesen als Clip liest die Region in einen neuen Clip auf der Spur des Cursors am Takt des Cursors, so lang wie die gelesenen Takte, ohne etwas zu überschreiben. Der Clip merkt sich, woher auf der Seite er kam: Mit dem Zeiger darüber seine Region wird auf der Seite umrandet, und Clip neu lesen (das Menü des Clips, oder das des Bild-Bereichs bei gewähltem Clip) liest ihn erneut. Eine Seite, eine Region oder einen Clip erneut zu lesen, ersetzt nur die Takte, die Sie seitdem nicht bearbeitet haben; ein bearbeiteter Takt bleibt, und „Prüfen“ bietet seine neue Lesung an.

Ignorierte Zonen

Manches auf einer Seite ist keine Musik zum Lesen: eine Überschrift, eine handschriftliche Notiz, ein Bild, ein Stempel. Ziehen Sie eine Region darum und wählen Sie Region ignorieren im Menü des Bereichs: Sie wird ein grau schraffierter Kasten mit der Aufschrift „Ignoriert“, und „Noten lesen“ lässt aus, was darunter liegt. Klicken Sie auf eine Zone, um sie zu wählen, ziehen Sie sie, um sie zu verschieben, oder ziehen Sie eine Ecke, um ihre Größe zu ändern; Ignorierte Zone entfernen (oder Delete) entfernt sie. Zonen werden mit der Seite im Song aufbewahrt, und jede Änderung ist ein Rückgängig-Schritt. Ein Foto nimmt Zonen an, sobald seine Seite aufbereitet ist.

BefehlTastenWo
Nächster zu prüfender Taktdas Menü „Transport“; das Menü des Elements „Bild-Bereich“
BefehlTastenWo
Nächster zu prüfender Taktdas Menü „Transport“; das Menü des Elements „Bild-Bereich“
BefehlTastenWo
Nächster zu prüfender Taktdas Menü „Transport“; das Menü des Elements „Bild-Bereich“