stab 帮助

14. 导入音乐

PDF 与“识别乐谱”

由打谱或六线谱 App 导出的 PDF 以绘制的线条和文字保存音乐,Stab 会把它们读回来:音符及其节奏、TAB 的品位、鼓,以及页面上的文字。扫描的 PDF 则保存其页面的图片,Stab 也能识别它们,就像识别照片一样。PDF 会随歌曲保留,放在它旁边,这样你就可以对照页面检查识别的内容。

PDF 与“识别乐谱”

适用于 每个平台。

Stab 识别什么

Stab 识别由 App 生成的 PDF(从打谱或六线谱程序导出或打印为 PDF,包括 Stab 本身)以及扫描的 PDF。在它们的页面上,它会识别:

  • 五线谱:谱号、调号和拍号、每行谱表最多两个声部的音符和休止符、临时记号、连音、延音线、弱起小节、反复和结尾、速度记号。
  • TAB:每根弦上的品位,以及页面上写明的调弦。单独印刷、节奏写在谱表下方的 TAB 也能识别。
  • 鼓,在打击乐谱表上。
  • 页面上的文字:标题、歌词、和弦符号和段落名称。

跨越多行谱表和多页的声部会各自合并为一条音轨。

扫描的 PDF

扫描的 PDF 保存的是其页面的图片,而不是绘制的音乐。Stab 会像识别照片一样识别它们:每一页都会被清理和拉直,找到其谱表,然后在你的电脑上运行的“识别乐谱”模型会识别其中的符号。歌曲会在扫描页面旁边打开,这些页面会自动一页接一页地被识别;“图像”面板底部会显示进度,然后显示识别了多少小节、有多少需要检查。一页需要几秒钟(搭载 Apple 芯片的 Mac;在 Intel Mac 上最多约 15 秒)。

同时包含两种页面(一些是绘制的,一些是扫描的)的 PDF,会立即识别其绘制的页面,然后识别其扫描的页面,全部识别到同一首歌曲中。扫描的页面会作为一份单独的文稿保存在 PDF 旁边。

识别扫描件不如识别绘制的 PDF 可靠,所以需要检查的小节会更多。以 300 dpi 扫描的清晰、端正的页面识别效果最好;模糊、浅淡或字迹很小的印刷识别效果较差,手写乐谱无法识别。如果你有当初写这份乐谱的程序,从它导出的 PDF 能被准确识别。见“识别乐谱”故障排除。

扫描的 PDF 保存的是其页面的图片,而不是绘制的音乐,网页无法识别它们:打开时会说明这一点。请在 Mac、PC、iPhone、iPad 或 Android 上的 Stab 中打开它,它们可以识别扫描件。

打开 PDF

  1. 从“文件”菜单中选择 打开… (⌘O)打开… (Ctrl+O)导入…,或主页上导入歌曲下的导入文件。 在主页上的导入歌曲下,选择导入文件。
  2. 选取 PDF。
你也可以把 PDF 拖到主页或歌曲的窗口上。
你也可以把它拖到主页上的任意位置。第一次打开 PDF 时,网页会载入其 PDF 阅读器。

歌曲打开时,左边是乐谱,右边是显示 PDF 页面的“图像”面板,两者相互链接。一条消息会说明识别了多少小节,以及有多少需要检查。歌曲会像任何导入一样放入你的资料库,以第一页上的标题命名,否则以文件名命名。在网页上,歌曲会作为一首演示曲打开供你试用;离开时选择保留到 Stab Cloud 即可保留它(见“欢迎”演示曲)。

这条消息还会提供识别方式:在 Windows 上,它是一个单独的对话框。

  • 保留页面的版式会在乐谱中保留印刷的谱行、符干、符杠和记法;重新排版让 Stab 像排版它自己的歌曲一样排版。
  • 不确定的小节:保留最佳猜测,或留空(一个与小节等长的休止符)。无论哪种方式,这个小节都保持为待检查。
  • 反复:保留(反复记号和结尾),或忽略(按印刷的样子,小节只出现一次)。
  • 复查会立即逐个处理需要检查的小节(见下文)。

更改某个选项时,PDF 会按它重新识别。你的选择会被记住,用于下一份 PDF 以及“识别乐谱”;“设置”中有同样的选项(编辑 › 识别印刷乐谱乐谱页面中“识别乐谱”的几行)。之后你可以用乐谱面板 ⚙ 菜单中的重新排版更改排版。

乐谱会保留页面的版式:它的谱行、符干、符杠和记法。乐谱面板 ⚙ 菜单中的重新排版会像 Stab 排版它自己的歌曲一样排版。它还会清除你手动设定的符干、符杠和跨谱表选择(重新排版)。不确定的小节和反复如何识别,在“设置”(乐谱 › 识别印刷乐谱)和“图像”面板的菜单中设定。

检查识别的内容

识别印刷乐谱并不完美,Stab 会告诉你它在哪些地方不太确定:

  • “图像”面板会在页面上框出待检查的小节,歌曲打开时的消息会说明有多少个。
  • 下一个待检查的小节 会依次跳到每一个。
  • 复查会逐个带你处理它们(见下文)。
  • 在编辑器中,音符着色依据 › 置信度会按识别的把握程度为每个音符着色。

把一个小节与页面比较,播放它,然后像修改其他音符一样修正错误的地方。编辑待检查小节中的音符会把它标记为已检查。

命令按键位置
打开…⌘O“文件”菜单; 主页 › Import…
命令按键位置
打开…Ctrl+O“文件”菜单; 主页 › Import…
命令按键位置
导入…主页

复查识别的内容

适用于 每个平台。

“复查”会逐个显示待检查的小节,每个都在页面上它所在的区域旁边:“图像”面板旁边的乐谱或编辑器会跳到这个小节,页面会滚动到它并把它框出来。在一次识别后,用“图像”面板底部的复查开始,或用“编辑”菜单中的 复查识别的小节,用打开 PDF 后消息中的复查,或用“图像”面板菜单中的复查识别的小节。

“图像”面板顶部的一个条带会显示你所在的位置(“复查 · 3/9”),并为显示的小节提供:

  • 接受:这个小节本身就是对的;它不再标记为待检查,“复查”会继续下一个。
  • 修正:“复查”会停在这个小节上,并选中其音符,乐谱面板接收键盘输入。用乐谱的工具编辑它,然后选择继续复查(在乐谱上方的胶囊按钮、条带或菜单中)继续。
  • 重新识别:页面上这个小节的区域会被单独重新识别。
  • 留空:一个与小节等长的休止符,仍标记为待检查。
  • 使用新的识别结果:对于你在页面或片段被重新识别之前就编辑过的小节,为它单独保留的新识别结果。
  • ‹ 和 › 后退和前进;完成结束“复查”。

每一项都是一个撤销步骤。“复查”进行时,按键在歌曲的任何面板中都有效:Return 接受,箭头逐个移动,Escape 结束,F、R、E 和 N 分别是修正、重新识别、留空和使用新的识别结果。越过最后一个小节会结束“复查”,并说明还有多少个待检查。

命令按键位置
复查识别的小节“编辑”菜单
结束复查“编辑”菜单; Review strip
接受Review strip
修正Review strip
重新识别Review strip
留空Review strip
使用新的识别结果Review strip
下一小节Review strip
上一小节Review strip
命令按键位置
复查识别的小节“编辑”菜单
结束复查“编辑”菜单; Review strip
接受Review strip
修正Review strip
重新识别Review strip
留空Review strip
使用新的识别结果Review strip
下一小节Review strip
上一小节Review strip
命令按键位置
复查识别的小节“编辑”菜单
结束复查“编辑”菜单; Review strip
接受Review strip
修正Review strip
重新识别Review strip
留空Review strip
使用新的识别结果Review strip
下一小节Review strip
上一小节Review strip

“图像”面板

适用于 每个平台。

“图像”面板显示歌曲的一份文稿:一份 PDF,或印刷乐谱的照片。从 PDF 打开的歌曲会自动得到一个;在其他任何歌曲中,把一个面板的类型设为“图像”(面板),然后向其中添加一份文稿。

跟着阅读

页面上下排列。滚动浏览它们,双指捏合缩放,或使用面板菜单中的放大和缩小。光标所在的小节会在页面上被框出。通过链接颜色与编辑器或乐谱链接时,面板会跟随它们的光标,点按页面上的一个小节,就会把它们的光标放到那个小节上。把指针悬停在页面的一个音符上,会显示那里识别出了什么。

面板的菜单

右键点按面板即可打开它的菜单:

  • 识别乐谱、识别所有页面(两页或以上的文稿)、在区域内识别乐谱、识别乐谱为片段、重新识别片段、清除区域:见下文。
  • 忽略区域、移除忽略区域、移除此页上的忽略区域:见下文。
  • 识别选项:保留页面的版式、不确定的小节和反复,如上所述。
  • 下一个待检查的小节、复查识别的小节(修正小节时为继续复查)、结束复查。
  • 跟随光标、适合宽度、放大、缩小。
  • 显示 › 待检查的小节,对于照片还有原始照片和框出谱表。在“设置”(乐谱 › 识别印刷乐谱)中打开显示识别详细信息时,“显示”会加入“识别乐谱”在页面上看到和生成的每一层内容(谱表、符号、置信度、文字、识别结果、清理),指针还会说明每个符号变成了什么。
  • 导出带图层的页面…:一张页面及其上方绘制内容的图片,在 Stab 识别错误时用来发送。
  • 歌曲的各份文稿,用来显示另一份;添加文稿…用来添加 PDF 或图片;移除文稿。
在一页包含多首曲目的曲集页面上,识别选项 › 一页上有多首曲目可以在识别为一首歌曲(每首曲目处一个标记)和每首识别为单独的歌曲(第一首在你识别的地方,其余的成为各自的新歌曲)之间选择。

文稿保存在歌曲的文件中。添加或移除文稿不是撤销步骤。

识别乐谱

“识别乐谱”会把一页或其中一部分识别到你正在处理的歌曲中:

  1. 在“图像”面板中显示该页面,并把光标放到音乐应该放入的位置(在另一个面板中,或通过点按页面上的一个小节)。
  2. 要只识别页面的一部分,请拖出一个矩形把它围起来:用鼠标拖动。
  3. 从面板的菜单中选择在光标处识别乐谱(在还没有音符的歌曲中为识别乐谱),或在区域内识别乐谱。

识别的内容作为一个撤销步骤放入。放入还没有音符的歌曲时,识别出的每个声部都会成为一条音轨,并带有其拍号、速度和调。放入已有音符的歌曲时,适合光标所在音轨的声部(有品位的音轨用六线谱,键盘用键盘,鼓用鼓)会从光标所在的小节开始放在那里,放在它自己的片段中;如果那里已经有片段,它会放在一个新的声部上,所以不会覆盖任何内容。识别所有页面会把文稿的每一页识别到歌曲中,跨越翻页连接起来。

识别乐谱为片段会把区域识别到光标所在音轨上、光标所在小节处的一个新片段中,长度与识别出的小节相同,不覆盖任何内容。片段会记住它来自页面上的哪个位置:把指针悬停在它上面会在页面上框出它的区域,重新识别片段(在片段的菜单中,或选取片段后在“图像”面板的菜单中)会再次识别它。再次识别页面、区域或片段,只会替换你自那以后没有编辑过的小节;你编辑过的小节会保留,“复查”会为它提供新的识别结果。

忽略区域

页面上有些东西不是要识别的音乐:标题、手写的笔记、图片、印章。拖出一个区域把它围起来,然后从面板的菜单中选择忽略区域:它会变成一个标有“已忽略”的灰色斜线框,“识别乐谱”会略过它下面的内容。点按一个区域即可选取它,拖动它即可移动,拖动一个角即可调整大小;移除忽略区域(或按 Delete)会移除它。区域随页面保存在歌曲中,每次更改都是一个撤销步骤。照片的页面在清理后才能设置区域。

命令按键位置
下一个待检查的小节“走带”菜单; “图像”面板的菜单
命令按键位置
下一个待检查的小节“走带”菜单; “图像”面板的菜单
命令按键位置
下一个待检查的小节“走带”菜单; “图像”面板的菜单