stab 帮助

21. 平台指南

Mac 上的 Stab

Mac 上的 Stab 是通常意义上的 Mac 应用:每首歌曲一个窗口、菜单栏、程序坞,以及用 ⌘, 打开的设置。本页介绍 Mac 特有的内容:安装、歌曲保存在哪里、macOS 请求的权限,以及声音和 MIDI 如何到达 Stab。

Mac 上的 Stab

适用于 Mac。 不适用于 Windows和网页。

Windows 上没有这项功能。

网页 上没有这项功能。

安装 Stab

Stab 可在 macOS 14 或更高版本上运行,支持搭载 Apple 芯片和 Intel 处理器的 Mac。

  1. 从 stab.audio 下载 Stab:一个磁盘映像,Stab-版本.dmg。
  2. 打开它,把 Stab 拖到旁边的应用程序文件夹上。
  3. 从“应用程序”中打开 Stab。这个应用已经过 Apple 公证,所以 macOS 只会询问一次你是否要打开从互联网下载的应用,然后就会打开它。

之后你可以推出磁盘映像。要移除 Stab,请把它从“应用程序”拖到废纸篓;你的歌曲会留在原处。

关闭最后一个窗口不会退出 Stab:主页会保留,点按程序坞中的 Stab 图标会让它回来。

歌曲保存在哪里

你的歌曲在文稿 › Stab 中,每首一个文件,主页顶部 Stab 名称下方会显示位置。要保存在其他地方,请在设置 › 通用 › 资料库中选择另一个文件夹:见资料库文件夹。歌曲打开时在访达中被重新命名或移动,会继续保存到新的位置。

当 macOS 不让 Stab 访问“文稿”时

Stab 第一次打开时,macOS 会询问是否允许 Stab 访问你“文稿”文件夹中的文件(“Stab 把你的歌曲保存在‘文稿’中的 Stab 文件夹里。”)。请选择允许。如果拒绝了,Stab 就无法打开它的文件夹,主页会在歌曲的位置显示一张卡片:“Stab 无法打开其歌曲文件夹”,并说明“Stab 将你的歌曲保存在文稿 › Stab 中,但系统不允许它访问。”

在获得访问权限之前,Stab 不会新建歌曲或导入文件:你尝试时,它会显示“暂时无法保存新歌曲”,并提供同样的解决办法。Stab Cloud、演示曲以及从其他位置打开的歌曲仍然可以使用。

要让 Stab 访问:

  1. 选择卡片上的打开隐私设置。它会打开系统设置 › 隐私与安全性 › 文件和文件夹。
  2. 在列表中找到 Stab,打开它下面的“文稿”文件夹。
  3. 回到 Stab。每次它来到前台时都会再次尝试访问这个文件夹,你的歌曲就会出现。

也可以选择选取其他文件夹…,把歌曲保存在别处。如果文件夹位于未连接的驱动器上,卡片会改为显示“Stab 找不到其歌曲文件夹”,并带有再试一次。

其他权限

  • 麦克风:在第一次有功能需要聆听时请求,例如调音器或录音。见听不到麦克风。
  • 本地网络:在你第一次在同一 Wi-Fi 上一起演奏时请求(“Stab 会在这个 Wi-Fi 上查找并加入与你一起演奏的人。”)。关闭时,附近的人就找不到你;见无法加入或主持会话。

更新

从 stab.audio 获取的 Stab 会自行更新。第二次打开它时,它会询问是否自动检查更新;如果你同意,它每天检查一次。Stab 菜单中的 检查更新…检查更新… (网页 上不可用) 会立即检查。见更新。

声音和 MIDI

Stab 通过“音频与 MIDI”面板的音频标签页中选择的输出播放,一开始为系统默认输出,并通过它的输入录音和调音:见音频输入。每首打开的歌曲都通过同一个输出播放,开始播放一首会停止其他歌曲。

MIDI 设备插入后会出现在设置 › 音频与 MIDI 和“音频与 MIDI”面板中。Stab 还会作为名为“Stab”的 MIDI 信号源出现在其他音乐应用中:把一条音轨发送到 Stab (to Other Apps),就可以从你的歌曲演奏另一个应用的乐器(MIDI 输出与时钟)。

“乐器”面板(⌃⌘K)可以用鼠标演奏光标所在的音轨,或者使用“音乐键入”,用电脑的键盘演奏。“设置” › “音频与 MIDI”顶部的音频缓冲区会在你现场演奏时让输出的缓冲区保持较短。

Stab 播放它自己的乐器和效果器,以及你的 VST3 和 Audio Unit 格式的效果器插件(插件)。它不加载 CLAP 插件或乐器插件。

Mac 特有的功能

  • 一首歌曲可以在单独的窗口中打开,一个面板也可以(窗口)。窗口 › 前置全部窗口会把它们集中起来,主页 (⇧⌘H)主页 (Ctrl+Shift+H)主页 显示主页。
  • 文件 › 打开最近使用列出你最近打开的歌曲。
  • 文件 › 导入 iReal Pro 链接…用你拷贝的 iReal Pro 链接新建一首歌曲。
  • 作为参考的 YouTube 视频可以在 Mac(以及网页版)上使用。
  • Mac 没有用于外接显示器的镜像到显示器;请改为把窗口拖到另一块屏幕上。

按键

Stab 遵循 Mac 的按键:⌘ 用于命令,⌥ 和 ⇧ 用于变化。见键盘快捷键,完整列表见各平台的快捷键。